Ubuntu 16.04LTSでWordPressを使うまでのメモ

以前 Ubuntu 14.04LTSでLEMP環境で使う場合のメモ書きとして投稿しましたが、今回Ubuntu 16.04 LTSが出たので、最新の情報に更新しておきます。

Ubuntu 14.04LTSでWordPressを使うまでのメモ

まず、構築する構成は以下のとおり

  • Ubuntu 16.04 LTS
  • Nginx
  • PHP 7.0
  • MariaDB

今回はさくらのVPS上にカスタムOSとして Ubuntu 16.04をインストールした直後を想定します。 “Ubuntu 16.04LTSでWordPressを使うまでのメモ” の続きを読む

HTTP/2時代のnginx+WordPress運用

この記事は nginx Advent Calendar 2015 ・ WordPress Advent Calendar 2015 の24日目のエントリです。

どうも、やまけんです。一度はIT系なAdvent Calendarでも書いてみようかなと思ってたんですが、まだnginxとWordPressに空きがあったので、投稿することにしました。


もくじ

  • HTTP/2 使っていますか?
  • HTTP/2 とは
  • WordPress+nginx+HTTP/2で必要なもの
  • 設定しよう

HTTP/2使ってますか?

新しもの好きな私は、早速導入しました。皆さんご覧いただいているこのページもHTTP/2対応ブラウザから見れば、HTTP/2にてブラウジングができているのがわかります。 “HTTP/2時代のnginx+WordPress運用” の続きを読む

ubuntu + nginx + php-fpm で、最近apt-get upgradeしてから php-fpmが動かなくなった

長い件名ですが、いままで nginx + php-fpmにて動かしていて、apt-get upgradeしてからphpが動作しなくなったという事例の解決法です。
実は私もハマりました。

原因 : PHPのパッケージの更新によって、セキュリティー対策がされたため。

大本は、 CVE-2014-0185 というセキュリティ不具合の修正によって、アクセス権限が強化されたためです。

“ubuntu + nginx + php-fpm で、最近apt-get upgradeしてから php-fpmが動かなくなった” の続きを読む